Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-22205

Upgrade zookeeper and curator versions

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0.0
    • Fix Version/s: 4.0.0
    • Component/s: HiveServer2
    • Labels:
      None
    • Target Version/s:

      Description

      Other components like hadoop have switched to using new ZK versions. So these jars end up in classpath for hive services and could cause issues due to in-compatible curator versions that hive uses.

      So it makes sense for hive to upgrade the ZK and curator versions to try to keep up.

        Attachments

        1. HIVE-22205.2.patch
          22 kB
          Naveen Gangam
        2. HIVE-22205.3.patch
          25 kB
          Naveen Gangam
        3. HIVE-22205.4.patch
          25 kB
          Naveen Gangam
        4. HIVE-22205.6.patch
          32 kB
          Naveen Gangam
        5. HIVE-22205.7.patch
          31 kB
          Naveen Gangam
        6. HIVE-22205.patch
          0.7 kB
          Naveen Gangam

          Issue Links

          There are no Sub-Tasks for this issue.

            Activity

              People

              • Assignee:
                ngangam Naveen Gangam
                Reporter:
                ngangam Naveen Gangam
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: