Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-19790

Fix compatibility break in 1.3.2-SNAPSHOT

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.3.2
    • Fix Version/s: 1.3.2
    • Component/s: None
    • Labels:
      None

      Description

      This change is disallowed in a patch release:

      package org.apache.hadoop.hbase.regionserver
      interface Region 
      
      Abstract method closeRegionOperation ( Region.Operation ) has been added to this interface.
      
      Recompilation of a client program may be terminated with the message: a client class C is not abstract and does not override abstract method closeRegionOperation ( Region.Operation ) in Region.
      

      Region is a LimitedPrivate(COPROC) interface.

      See https://hbase.apache.org/book.html#hbase.versioning

      New APIs introduced in a patch version will only be added in a source compatible way [1]: i.e. code that implements public APIs will continue to compile.

        Attachments

        1. HBASE-19790-branch-1.3.patch
          3 kB
          Andrew Kyle Purtell

          Activity

            People

            • Assignee:
              apurtell Andrew Kyle Purtell
              Reporter:
              apurtell Andrew Kyle Purtell
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: