Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-22563

Required field 'client_protocol' is unset (hive server backward compatibility)

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 1.2.1, 2.3.6
    • Fix Version/s: None
    • Component/s: Hive
    • Labels:
      None

      Description

      I try to connect to hive server 1.2.1 by using hive client (hive-jdbc-2.3.6.jar) , then I got this issue "Required field 'client_protocol' is unset".  Is that means hive server 1.2.1 has no backward compatibility for newer hive client version?   

        Attachments

        1. image-2019-11-29-10-20-46-982.png
          56 kB
          ZhangZhiCheng

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ZhangZhiCheng ZhangZhiCheng
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Due:
                Created:
                Updated: