Details

    • Release Note:
      Added SLF4J binding for LOG4J 2.

      Description

      Currently hbase-operator-tools uses org.apache.logging.log4j while the rest of our projects have SLF4J.

      When building the project with release profile the enforce plugin fails on  org.apache.logging.log4j:log4j-api:jar:2.11.1 dependency

      [INFO] --- maven-enforcer-plugin:1.4:enforce (min-maven-min-java-banned-xerces) @ hbase-hbck2 ---
      [INFO] Restricted to JDK 1.8 yet org.apache.logging.log4j:log4j-api:jar:2.11.1:compile contains META-INF/versions/9/module-info.class targeted to JDK 1.9
      [WARNING] Rule 3: org.apache.maven.plugins.enforcer.EnforceBytecodeVersion failed with message:
      HBase has unsupported dependencies.
        HBase requires that all dependencies be compiled with version 1.8 or earlier
        of the JDK to properly build from source.  You appear to be using a newer dependency. You can use
        either "mvn -version" or "mvn enforcer:display-info" to verify what version is active.
        Non-release builds can temporarily build with a newer JDK version by setting the
        'compileSource' property (eg. mvn -DcompileSource=1.8 clean package).
      Found Banned Dependency: org.apache.logging.log4j:log4j-api:jar:2.11.1
      Use 'mvn dependency:tree' to locate the source of the banned dependencies. 

        Attachments

          Activity

            People

            • Assignee:
              psomogyi Peter Somogyi
              Reporter:
              psomogyi Peter Somogyi
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: