Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-13428 [DOC] Migration to hbase-2.0.0
  3. HBASE-20279

[tooling] check for incompatible environment for HBase 2.0 upgrade

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 2.0.0
    • Fix Version/s: None
    • Component/s: documentation, tooling
    • Labels:
      None

      Description

      from Michael Stack on HBASE-19158:

      Server failure. HBase can still read HFiles written in the older version 2 format.

      Need a script that user can run pre-upgrade.

      Additional commentary from Sean Busbey

      In addition to the config check stack mentions, such a tool could check

      • other problematic configs, like those for master-hosts-regions
      • inconsistent configs due to changed defaults (I think we should have some smell-tests around the change in default for hbase.security.authorization)
      • (optionally) check for unreadable WALs
      • (optionally) check for unreadable hfiles

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              busbey Sean Busbey
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: