Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-20089

make_rc.sh should name SHA-512 checksum files with the extension .sha512

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.2, 1.4.3, 2.0.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      From Josh Elser

      we need to update the checksum naming convention for SHA*. Per [1], .sha filenames should only contain SHA1, and .sha512 file names should be used for SHA512 xsum. I believe this means we just need to modify make_rc.sh to put the xsum into .sha512 instead of .sha. We do not need to distribute SHA1 xsums and, afaik, there is little cryptographic value to this.

      [1] http://www.apache.org/dev/release-distribution.html#sigs-and-sums

        Attachments

        1. HBASE-20089.001.patch
          1 kB
          Josh Elser

          Activity

            People

            • Assignee:
              elserj Josh Elser
              Reporter:
              apurtell Andrew Kyle Purtell
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: