Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-19145

Look into hbase-2 client going to hbase-1 server

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.0.0-beta-1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      From the "[DISCUSS] hbase-2.0.0 compatibility expectations" thread.

      Do we support hbase-2 client going against hbase-1 server?
      We seem to be fine mix-and-match the clients and servers within the
      hbase-1 releases. And IIRC hbase-1 client is ok against 0.98 server.
      Suppose I have a product that depends and bundles HBase client. I
      want to upgrade the dependency to hbase-2 so that it can take
      advantages of and claim support of hbase-2.
      But does it mean that I will need drop the claims that the new version
      of the product support any hbase-1 backend?

      It has not been an objective. It might work doing basic Client API on a
      later branch-1 but will fail doing Admin functions (and figuring if a Table
      is online). If it was a small thing to make it
      work, lets get it in.

      Let's look into it to see what works and what not. Have a statement at least.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jinghe Jerry He
                Reporter:
                jinghe Jerry He
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: