Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-6727

Travis deprecated xcode 6.4 (used for wheel files)

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.12.0
    • Component/s: sdk-py-core
    • Labels:
      None

      Description

      I noticed the following lines in the travis logs (used from: https://github.com/apache/beam-wheels)

      Running builds with Xcode 6.4 in Travis CI is deprecated and will be removed in January 2019.
      If Xcode 6.4 is critical to your builds, please contact our support team at support@travis-ci.com to discuss options.
      Services are not supported on osx

      We need to change the version we are using to build wheel files.
      Lots of newer versions are already supported: https://docs.travis-ci.com/user/reference/osx/#macos-version

      Robert Bradshaw[Boyuan Zhang is there a reason for us to use xcode 6.4 here?

      (Not release blocking because builds are still working even though there is a warning.)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                robertwb Robert Bradshaw
                Reporter:
                altay Ahmet Altay
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m