Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-4850

Remove dependency on google-apitools package in Python SDK.

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: sdk-py-core
    • Labels:
      None

      Description

      AFAIK google-apitools is not officially supported. For Google Cloud Platform APIs such as Datastore, Cloud Storage or Pub/Sub, using Cloud Client Libraries for Python is recommended. If that not possible, we may be able to use https://github.com/google/google-api-python-client - officially supported, but now in maintenance mode.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tvalentyn Valentyn Tymofieiev
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 1h 20m
                  1h 20m