Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-4543

Remove dependency on googledatastore in favor of google-cloud-datastore.

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: sdk-py-core
    • Labels:

      Description

      apache-beam[gcp] package depends [1] on googledatastore package [2]. We should replace this dependency with google-cloud-datastore [3] which is officially supported, has better release cadence and also has Python 3 support.

      [1] https://github.com/apache/beam/blob/fad655462f8fadfdfaab0b7a09cab538f076f94e/sdks/python/setup.py#L126

      [2] https://pypi.org/project/googledatastore/

      [3] https://pypi.org/project/google-cloud-datastore/

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                udim Udi Meiri
                Reporter:
                tvalentyn Valentyn Tymofieiev
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: